Discussion:
FM2019 - 32/64-bit?
(too old to reply)
Scott Prentice
2018-09-24 17:06:09 UTC
Permalink
If/when you upgrade to FM2019 (or beyond), would any of you be using the
32-bit version? As a plugin developer, I'm thinking that I'll only
support 64-bit FM. Is there a reason to support both?

Yes, I've heard that some people will need to run 32-bit FM due to
legacy applications .. are there any other reasons?

Thanks!
...scott

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com
Robert Lauriston
2018-09-24 17:12:06 UTC
Permalink
The main reason to run the 32-bit version of FrameMaker is that there
is no 64-bit version.

https://forums.adobe.com/thread/2447691
Post by Scott Prentice
If/when you upgrade to FM2019 (or beyond), would any of you be using the
32-bit version? As a plugin developer, I'm thinking that I'll only support
64-bit FM. Is there a reason to support both?
Yes, I've heard that some people will need to run 32-bit FM due to legacy
applications .. are there any other reasons?rs.com
_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com
Scott Prentice
2018-09-24 17:47:56 UTC
Permalink
FM2019 is available as 32-bit and 64-bit. That forum post is talking
about FM2017.

Thanks,
...scott
Post by Robert Lauriston
The main reason to run the 32-bit version of FrameMaker is that there
is no 64-bit version.
https://forums.adobe.com/thread/2447691
Post by Scott Prentice
If/when you upgrade to FM2019 (or beyond), would any of you be using the
32-bit version? As a plugin developer, I'm thinking that I'll only support
64-bit FM. Is there a reason to support both?
Yes, I've heard that some people will need to run 32-bit FM due to legacy
applications .. are there any other reasons?rs.com
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com
Ian Proudfoot
2018-09-24 18:20:13 UTC
Permalink
Scott,


There may be a need to run the 32 bit version if you run into ExtendScript ScriptUI bugs that are only present in the 64 bit version. Hopefully this is a temporary problem...




Ian




Ian Proudfoot


iTP-X




Bembridge


Isle of Wight


07793 324581







On Mon, Sep 24, 2018 at 6:48 PM +0100, "Scott Prentice" <***@leximation.com> wrote:










FM2019 is available as 32-bit and 64-bit. That forum post is talking
about FM2017.

Thanks,
...scott
Post by Robert Lauriston
The main reason to run the 32-bit version of FrameMaker is that there
is no 64-bit version.
https://forums.adobe.com/thread/2447691
Post by Scott Prentice
If/when you upgrade to FM2019 (or beyond), would any of you be using the
32-bit version? As a plugin developer, I'm thinking that I'll only support
64-bit FM. Is there a reason to support both?
Yes, I've heard that some people will need to run 32-bit FM due to legacy
applications .. are there any other reasons?rs.com
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com





_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com
Scott Prentice
2018-09-24 20:19:53 UTC
Permalink
Thanks Ian.

Yeah .. I suppose if something is broken in the 64-bit version and it's
working in the 32-bit version, that might be a reason to use it. But if
all's working as expected, I'm just not seeing a reason to use the
32-bit version.

I suppose someone could be using a 32-bit version of Windows, and want
to install FM2019 .. but really? I guess we'll just have to wait and see,

Cheers,
...scott
Post by Ian Proudfoot
Scott,
There may be a need to run the 32 bit version if you run into ExtendScript ScriptUI bugs that are only present in the 64 bit version. Hopefully this is a temporary problem...
Ian
Ian Proudfoot
iTP-X
Bembridge
Isle of Wight
07793 324581
FM2019 is available as 32-bit and 64-bit. That forum post is talking
about FM2017.
Thanks,
...scott
Post by Robert Lauriston
The main reason to run the 32-bit version of FrameMaker is that there
is no 64-bit version.
https://forums.adobe.com/thread/2447691
Post by Scott Prentice
If/when you upgrade to FM2019 (or beyond), would any of you be using the
32-bit version? As a plugin developer, I'm thinking that I'll only support
64-bit FM. Is there a reason to support both?
Yes, I've heard that some people will need to run 32-bit FM due to legacy
applications .. are there any other reasons?rs.com
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com
Lin Sims
2018-09-24 20:47:36 UTC
Permalink
This is probably a stupid question, but my understanding is that a
scripting language is pure text interpreted by whichever interpreter (in
this case ExtendScript) is installed. If that's the case, does it matter
which version of FM you create the script in? Does the 32-bit version have
different command words and variables or syntax from the 64-bit?

NB: Not a scripter of any sort, haven't looked to see.
Post by Scott Prentice
Thanks Ian.
Yeah .. I suppose if something is broken in the 64-bit version and it's
working in the 32-bit version, that might be a reason to use it. But if
all's working as expected, I'm just not seeing a reason to use the
32-bit version.
I suppose someone could be using a 32-bit version of Windows, and want
to install FM2019 .. but really? I guess we'll just have to wait and see,
Cheers,
...scott
Post by Ian Proudfoot
Scott,
There may be a need to run the 32 bit version if you run into
ExtendScript ScriptUI bugs that are only present in the 64 bit version.
Hopefully this is a temporary problem...
Post by Ian Proudfoot
Ian
Ian Proudfoot
iTP-X
Bembridge
Isle of Wight
07793 324581
FM2019 is available as 32-bit and 64-bit. That forum post is talking
about FM2017.
Thanks,
...scott
Post by Robert Lauriston
The main reason to run the 32-bit version of FrameMaker is that there
is no 64-bit version.
https://forums.adobe.com/thread/2447691
Post by Scott Prentice
If/when you upgrade to FM2019 (or beyond), would any of you be using
the
Post by Ian Proudfoot
Post by Robert Lauriston
Post by Scott Prentice
32-bit version? As a plugin developer, I'm thinking that I'll only
support
Post by Ian Proudfoot
Post by Robert Lauriston
Post by Scott Prentice
64-bit FM. Is there a reason to support both?
Yes, I've heard that some people will need to run 32-bit FM due to
legacy
Post by Ian Proudfoot
Post by Robert Lauriston
Post by Scott Prentice
applications .. are there any other reasons?rs.com
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Post by Ian Proudfoot
Post by Robert Lauriston
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Post by Ian Proudfoot
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Post by Ian Proudfoot
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Post by Ian Proudfoot
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Post by Ian Proudfoot
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
--
Lin Sims
_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com
Scott Prentice
2018-09-24 20:53:46 UTC
Permalink
You're right. It's not the script itself that might differ between
versions, but the code that interprets it might not work quite the same.
Not intentionally, but .. well .. sometimes code just doesn't work
right.  :-)

If the 64-bit version didn't work the same as the 32-bit version for the
same script, that would be a bug in FM, not a problem with the script.

Cheers,
...scott
Post by Lin Sims
This is probably a stupid question, but my understanding is that a
scripting language is pure text interpreted by whichever interpreter (in
this case ExtendScript) is installed. If that's the case, does it matter
which version of FM you create the script in? Does the 32-bit version have
different command words and variables or syntax from the 64-bit?
NB: Not a scripter of any sort, haven't looked to see.
Post by Scott Prentice
Thanks Ian.
Yeah .. I suppose if something is broken in the 64-bit version and it's
working in the 32-bit version, that might be a reason to use it. But if
all's working as expected, I'm just not seeing a reason to use the
32-bit version.
I suppose someone could be using a 32-bit version of Windows, and want
to install FM2019 .. but really? I guess we'll just have to wait and see,
Cheers,
...scott
Post by Ian Proudfoot
Scott,
There may be a need to run the 32 bit version if you run into
ExtendScript ScriptUI bugs that are only present in the 64 bit version.
Hopefully this is a temporary problem...
Post by Ian Proudfoot
Ian
Ian Proudfoot
iTP-X
Bembridge
Isle of Wight
07793 324581
FM2019 is available as 32-bit and 64-bit. That forum post is talking
about FM2017.
Thanks,
...scott
Post by Robert Lauriston
The main reason to run the 32-bit version of FrameMaker is that there
is no 64-bit version.
https://forums.adobe.com/thread/2447691
Post by Scott Prentice
If/when you upgrade to FM2019 (or beyond), would any of you be using
the
Post by Ian Proudfoot
Post by Robert Lauriston
Post by Scott Prentice
32-bit version? As a plugin developer, I'm thinking that I'll only
support
Post by Ian Proudfoot
Post by Robert Lauriston
Post by Scott Prentice
64-bit FM. Is there a reason to support both?
Yes, I've heard that some people will need to run 32-bit FM due to
legacy
Post by Ian Proudfoot
Post by Robert Lauriston
Post by Scott Prentice
applications .. are there any other reasons?rs.com
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Post by Ian Proudfoot
Post by Robert Lauriston
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Post by Ian Proudfoot
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Post by Ian Proudfoot
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Post by Ian Proudfoot
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Post by Ian Proudfoot
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions t
i***@itp-x.co.uk
2018-09-25 11:10:29 UTC
Permalink
Lin,
The specific problem that has affected the 64 bit version is due to a
problem with the ScriptUI tree view control. ScriptUI is the way we build
the User Interface for ExtendScript projects. In this case the tree view
does not show any text or allow nodes to be expanded. I have some
applications where this is a critical part of the workflow. Everything works
perfectly on 32 bit version.

Ian

-----Original Message-----
From: Framers
<framers-bounces+ian.proudfoot=itp-***@lists.frameusers.com> On Behalf
Of Lin Sims
Sent: 24 September 2018 21:48
To: Frame Users <***@lists.frameusers.com>
Subject: Re: [Framers] FM2019 - 32/64-bit?

This is probably a stupid question, but my understanding is that a scripting
language is pure text interpreted by whichever interpreter (in this case
ExtendScript) is installed. If that's the case, does it matter which version
of FM you create the script in? Does the 32-bit version have different
command words and variables or syntax from the 64-bit?

NB: Not a scripter of any sort, haven't looked to see.
Post by Scott Prentice
Thanks Ian.
Yeah .. I suppose if something is broken in the 64-bit version and
it's working in the 32-bit version, that might be a reason to use it.
But if all's working as expected, I'm just not seeing a reason to use
the 32-bit version.
I suppose someone could be using a 32-bit version of Windows, and want
to install FM2019 .. but really? I guess we'll just have to wait and see,
Cheers,
...scott
Post by Ian Proudfoot
Scott,
There may be a need to run the 32 bit version if you run into
ExtendScript ScriptUI bugs that are only present in the 64 bit version.
Hopefully this is a temporary problem...
Post by Ian Proudfoot
Ian
Ian Proudfoot
iTP-X
Bembridge
Isle of Wight
07793 324581
FM2019 is available as 32-bit and 64-bit. That forum post is talking
about FM2017.
Thanks,
...scott
Post by Robert Lauriston
The main reason to run the 32-bit version of FrameMaker is that
there is no 64-bit version.
https://forums.adobe.com/thread/2447691
Post by Scott Prentice
If/when you upgrade to FM2019 (or beyond), would any of you be using
the
Post by Ian Proudfoot
Post by Robert Lauriston
Post by Scott Prentice
32-bit version? As a plugin developer, I'm thinking that I'll only
support
Post by Ian Proudfoot
Post by Robert Lauriston
Post by Scott Prentice
64-bit FM. Is there a reason to support both?
Yes, I've heard that some people will need to run 32-bit FM due to
legacy
Post by Ian Proudfoot
Post by Robert Lauriston
Post by Scott Prentice
applications .. are there any other reasons?rs.com
_______________________________________________
This message is from the Framers mailing list
homepage at http://www.frameusers.com Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Post by Ian Proudfoot
Post by Robert Lauriston
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Post by Ian Proudfoot
_______________________________________________
This message is from the Framers mailing list
homepage at http://www.frameusers.com Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Post by Ian Proudfoot
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Post by Ian Proudfoot
_______________________________________________
This message is from the Framers mailing list
homepage at http://www.frameusers.com Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Post by Ian Proudfoot
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
_______________________________________________
This message is from the Framers mailing list
homepage at http://www.frameusers.com Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
--
Lin Sims
_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com Visit the list's homepage at
http://www.frameusers.com Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com
Rick Quatro
2018-09-25 11:54:11 UTC
Permalink
Hi Ian,

Did you try putting the tree-view control into a group? There is a related
bug where listboxes don't show any content in some environments unless they
are inside a group or panel. I am not sure if this applies to tree views or
not.

Rick Quatro
Carmen Publishing Inc.
***@frameexpert.com
585-729-6746 NEW!



-----Original Message-----
From: Framers <framers-bounces+rick=***@lists.frameusers.com> On
Behalf Of ***@itp-x.co.uk
Sent: Tuesday, September 25, 2018 7:10 AM
To: 'An email list for people using Adobe FrameMaker software.'
<***@lists.frameusers.com>
Subject: Re: [Framers] FM2019 - 32/64-bit?

Lin,
The specific problem that has affected the 64 bit version is due to a
problem with the ScriptUI tree view control. ScriptUI is the way we build
the User Interface for ExtendScript projects. In this case the tree view
does not show any text or allow nodes to be expanded. I have some
applications where this is a critical part of the workflow. Everything works
perfectly on 32 bit version.

Ian

-----Original Message-----
From: Framers
<framers-bounces+ian.proudfoot=itp-***@lists.frameusers.com> On Behalf
Of Lin Sims
Sent: 24 September 2018 21:48
To: Frame Users <***@lists.frameusers.com>
Subject: Re: [Framers] FM2019 - 32/64-bit?

This is probably a stupid question, but my understanding is that a scripting
language is pure text interpreted by whichever interpreter (in this case
ExtendScript) is installed. If that's the case, does it matter which version
of FM you create the script in? Does the 32-bit version have different
command words and variables or syntax from the 64-bit?

NB: Not a scripter of any sort, haven't looked to see.
Post by Scott Prentice
Thanks Ian.
Yeah .. I suppose if something is broken in the 64-bit version and
it's working in the 32-bit version, that might be a reason to use it.
But if all's working as expected, I'm just not seeing a reason to use
the 32-bit version.
I suppose someone could be using a 32-bit version of Windows, and want
to install FM2019 .. but really? I guess we'll just have to wait and see,
Cheers,
...scott
Post by Ian Proudfoot
Scott,
There may be a need to run the 32 bit version if you run into
ExtendScript ScriptUI bugs that are only present in the 64 bit version.
Hopefully this is a temporary problem...
Post by Ian Proudfoot
Ian
Ian Proudfoot
iTP-X
Bembridge
Isle of Wight
07793 324581
FM2019 is available as 32-bit and 64-bit. That forum post is talking
about FM2017.
Thanks,
...scott
Post by Robert Lauriston
The main reason to run the 32-bit version of FrameMaker is that
there is no 64-bit version.
https://forums.adobe.com/thread/2447691
Post by Scott Prentice
If/when you upgrade to FM2019 (or beyond), would any of you be using
the
Post by Ian Proudfoot
Post by Robert Lauriston
Post by Scott Prentice
32-bit version? As a plugin developer, I'm thinking that I'll only
support
Post by Ian Proudfoot
Post by Robert Lauriston
Post by Scott Prentice
64-bit FM. Is there a reason to support both?
Yes, I've heard that some people will need to run 32-bit FM due to
legacy
Post by Ian Proudfoot
Post by Robert Lauriston
Post by Scott Prentice
applications .. are there any other reasons?rs.com
_______________________________________________
This message is from the Framers mailing list
homepage at http://www.frameusers.com Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Post by Ian Proudfoot
Post by Robert Lauriston
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Post by Ian Proudfoot
_______________________________________________
This message is from the Framers mailing list
homepage at http://www.frameusers.com Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Post by Ian Proudfoot
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Post by Ian Proudfoot
_______________________________________________
This message is from the Framers mailing list
homepage at http://www.frameusers.com Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Post by Ian Proudfoot
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
_______________________________________________
This message is from the Framers mailing list
homepage at http://www.frameusers.com Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
--
Lin Sims
_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com Visit the list's homepage at
http://www.frameusers.com Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com Visit the list's homepage at
http://www.frameusers.com Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com
4XScripts
2018-09-25 12:01:52 UTC
Permalink
Hi Rick,

the problem is, that Extendscript seems to have forgotten about
"node"-object in 64-bit. In 32-bit it works.

All items are added to treeview object instead of the nodes they should
go to.
Post by Rick Quatro
Hi Ian,
Did you try putting the tree-view control into a group? There is a related
bug where listboxes don't show any content in some environments unless they
are inside a group or panel. I am not sure if this applies to tree views or
not.
Rick Quatro
Carmen Publishing Inc.
585-729-6746 NEW!
--
Klaus Göbel
(Entwicklung)
__________________________
4XScripts - Ute Mitschke
Münchenerstraße 35A
82362 Weilheim

Tel.: +49 881 12233116
+49 173 9439973

Mail: ***@4XScripts.com
https://4XScripts.com

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative
Rick Quatro
2018-09-25 12:50:12 UTC
Permalink
Do you know if anyone at Adobe is looking at the problem?

-----Original Message-----
From: Framers <framers-bounces+rick=***@lists.frameusers.com> On Behalf Of 4XScripts
Sent: Tuesday, September 25, 2018 8:02 AM
To: ***@lists.frameusers.com
Subject: Re: [Framers] FM2019 - 32/64-bit?

Hi Rick,

the problem is, that Extendscript seems to have forgotten about "node"-object in 64-bit. In 32-bit it works.

All items are added to treeview object instead of the nodes they should go to.
Post by Rick Quatro
Hi Ian,
Did you try putting the tree-view control into a group? There is a related
bug where listboxes don't show any content in some environments unless they
are inside a group or panel. I am not sure if this applies to tree views or
not.
Rick Quatro
Carmen Publishing Inc.
585-729-6746 NEW!
--
Klaus Göbel
(Entwicklung)
__________________________
4XScripts - Ute Mitschke
Münchenerstraße 35A
82362 Weilheim

Tel.: +49 881 12233116
+49 173 9439973

Mail: ***@4XScripts.com
https://4XScripts.com

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to
4XScripts
2018-09-25 13:49:17 UTC
Permalink
I don't know.

I've filed a bugreport:

https://tracker.adobe.com/#/view/FRMAKER-5296

But its status still is "open"
Post by Rick Quatro
Do you know if anyone at Adobe is looking at the problem?
--
Klaus Göbel
(Entwicklung)
__________________________
4XScripts - Ute Mitschke
Münchenerstraße 35A
82362 Weilheim


Mail: ***@4XScripts.com
https://4XScripts.com

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative quest
4XScripts
2018-09-26 08:26:35 UTC
Permalink
Hi Ian, hi Rick,

_priority updated from 'Normal' to 'Critical'_

https://tracker.adobe.com/#/view/FRMAKER-5296

So I wait for the next update ....
Post by 4XScripts
I don't know.
https://tracker.adobe.com/#/view/FRMAKER-5296
But its status still is "open"
Post by Rick Quatro
Do you know if anyone at Adobe is looking at the problem?
--
Klaus Göbel
(Entwicklung)
__________________________
4XScripts - Ute Mitschke
Münchenerstraße 35A
82362 Weilheim

Mail: ***@4XScripts.com
https://4XScripts.com

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions t
4XScripts
2018-09-26 09:22:48 UTC
Permalink
PLEASE VOTE FOR IT (button on the bottom right)

Hi Ian, hi Rick,

_priority updated from 'Normal' to 'Critical'_

https://tracker.adobe.com/#/view/FRMAKER-5296

So I wait for the next update ....
Post by 4XScripts
I don't know.
https://tracker.adobe.com/#/view/FRMAKER-5296
But its status still is "open"
Post by Rick Quatro
Do you know if anyone at Adobe is looking at the problem?
--
Klaus Göbel
(Entwicklung)
__________________________
4XScripts - Ute Mitschke
Münchenerstraße 35A
82362 Weilheim

Mail:***@4XScripts.com
https://4XScripts.com

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to listad
i***@itp-x.co.uk
2018-09-25 14:21:26 UTC
Permalink
Hi Rick,

Yes this was reported during the pre-release program. The bug was first seen on the penultimate build, so it was too late to fix before release.

Ian

-----Original Message-----
From: Framers <framers-bounces+ian.proudfoot=itp-***@lists.frameusers.com> On Behalf Of Rick Quatro
Sent: 25 September 2018 13:50
To: 'An email list for people using Adobe FrameMaker software.' <***@lists.frameusers.com>
Subject: Re: [Framers] FM2019 - 32/64-bit?

Do you know if anyone at Adobe is looking at the problem?

-----Original Message-----
From: Framers <framers-bounces+rick=***@lists.frameusers.com> On Behalf Of 4XScripts
Sent: Tuesday, September 25, 2018 8:02 AM
To: ***@lists.frameusers.com
Subject: Re: [Framers] FM2019 - 32/64-bit?

Hi Rick,

the problem is, that Extendscript seems to have forgotten about "node"-object in 64-bit. In 32-bit it works.

All items are added to treeview object instead of the nodes they should go to.
Post by Rick Quatro
Hi Ian,
Did you try putting the tree-view control into a group? There is a
related bug where listboxes don't show any content in some
environments unless they are inside a group or panel. I am not sure if
this applies to tree views or not.
Rick Quatro
Carmen Publishing Inc.
585-729-6746 NEW!
--
Klaus Göbel
(Entwicklung)
__________________________
4XScripts - Ute Mitschke
Münchenerstraße 35A
82362 Weilheim

Tel.: +49 881 12233116
+49 173 9439973

Mail: ***@4XScripts.com
https://4XScripts.com

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com Visit the list's homepage at http://www.frameusers.com Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com Visit the list's homepage at http://www.frameusers.com Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com

_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameuse
Robert Lauriston
2018-09-24 22:09:18 UTC
Permalink
Sorry. I'm not sure how I missed that.
FM2019 is available as 32-bit and 64-bit. That forum post is talking about
FM2017.
Thanks,
...scott
Post by Robert Lauriston
The main reason to run the 32-bit version of FrameMaker is that there
is no 64-bit version.
https://forums.adobe.com/thread/2447691
Post by Scott Prentice
If/when you upgrade to FM2019 (or beyond), would any of you be using the
32-bit version? As a plugin developer, I'm thinking that I'll only support
64-bit FM. Is there a reason to support both?
Yes, I've heard that some people will need to run 32-bit FM due to legacy
applications .. are there any other reasons?rs.com
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
_______________________________________________
This message is from the Framers mailing list
Visit the list's homepage at http://www.frameusers.com
Archives located at
http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at
http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
_______________________________________________

This message is from the Framers mailing list

Send messages to ***@lists.frameusers.com
Visit the list's homepage at http://www.frameusers.com
Archives located at http://www.mail-archive.com/framers%40lists.frameusers.com/
Subscribe and unsubscribe at http://lists.frameusers.com/listinfo.cgi/framers-frameusers.com
Send administrative questions to ***@frameusers.com
Loading...